UVA_1594: Ducci Sequence

42 篇文章 0 订阅

Description

A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1, a2, ... , an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:

( a 1, a 2, ... , a n) $\displaystyle \rightarrow$ (| a 1 - a 2|,| a 2 - a 3|, ... ,| a n - a 1|)
Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:

(8, 11, 2, 7) $\displaystyle \rightarrow$ (3, 9, 5, 1) $\displaystyle \rightarrow$ (6, 4, 4, 2) $\displaystyle \rightarrow$ (2, 0, 2, 4) $\displaystyle \rightarrow$ (2, 2, 2, 2) $\displaystyle \rightarrow$ (0, 0, 0, 0).
The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:

(4, 2, 0, 2, 0) $\displaystyle \rightarrow$ (2, 2, 2, 2, 4) $\displaystyle \rightarrow$ ( 0, 0, 0, 2, 2) $\displaystyle \rightarrow$ (0, 0, 2, 0, 2) $\displaystyle \rightarrow$ (0, 2, 2, 2, 2) $\displaystyle \rightarrow$ (2, 0, 0, 0, 2) $\displaystyle \rightarrow$

(2, 0, 0, 2, 0) $\displaystyle \rightarrow$ (2, 0, 2, 2, 2) $\displaystyle \rightarrow$ (2, 2, 0, 0, 0) $\displaystyle \rightarrow$ (0, 2, 0, 0, 2) $\displaystyle \rightarrow$ (2, 2, 0, 2, 2) $\displaystyle \rightarrow$ (0, 2, 2, 0, 0) $\displaystyle \rightarrow$

(2, 0, 2, 0, 0) $\displaystyle \rightarrow$ (2, 2, 2, 0, 2) $\displaystyle \rightarrow$ (0, 0, 2, 2, 0) $\displaystyle \rightarrow$ (0, 2, 0, 2, 0) $\displaystyle \rightarrow$ (2, 2, 2, 2, 0) $\displaystyle \rightarrow$ ( 0, 0, 0, 2, 2) $\displaystyle \rightarrow$ ...
Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.

Input

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n (3$ \le$n$ \le$15), which represents the size of a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making a loop does not exceed 1,000.

Output

Your program is to write to standard output. Print exactly one line for each test case. Print ` LOOP' if the Ducci sequence falls into a periodic loop, print ` ZERO' if the Ducci sequence reaches to a zeros tuple.The following shows sample input and output for four test cases.

Sample Input

4 
4 
8 11 2 7 
5 
4 2 0 2 0 
7 
0 0 0 0 0 0 0 
6 
1 2 3 1 2 3

Sample Output

ZERO 
LOOP 
ZERO 
LOOP


分析:每组数据就是一组元,放在一个vector中,保存每次的状态,判断是否为0,判断map中是否存在当前状态。


#include <iostream>
#include <map>
#include <vector>
#include <cmath>

using namespace std;
vector<int> pairs;
map<vector<int>,int> pairbuf;

int iszero()
{
	for(int i=0; i<pairs.size(); i++)
		if(pairs[i])return 0;
	return 1;
}

int main()
{
	int T;
	cin >> T;
	while(T--)
	{
		int n;
		cin >> n;
		pairs.clear(); pairbuf.clear();
		for(int i=0; i<n; i++)
		{
			int x;
			cin >> x;
			pairs.push_back(x);
		}

		int rnd = 0;
		while(1)
		{
			int z0 = pairs[0];
			for(int i=0; i<n-1; i++)
			{
				pairs[i]=abs(pairs[i]-pairs[i+1]);
			}
			pairs[n-1]=abs(pairs[n-1]-z0);
			if(iszero()){cout << "ZERO" << endl;break;}
			if(pairbuf.count(pairs)){cout << "LOOP" << endl; break;}
			pairbuf[pairs] = rnd;
			rnd++;
		}
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值