ZOJ - 1633 Big String

Description

We will construct an infinitely long string from two short strings: A = "^__^" (four characters), and B = "T.T" (three characters). Repeat the following steps:
  • Concatenate A after B to obtain a new string C. For example, if A = "^__^" and B = "T.T", then C = BA = "T.T^__^".
  • Let A = B, B = C -- as the example above A = "T.T", B = "T.T^__^".
Your task is to find out the n-th character of this infinite string.


Input

The input contains multiple test cases, each contains only one integer N (1 <= N <= 2^63 - 1). Proceed to the end of file.


Output

For each test case, print one character on each line, which is the N-th (index begins with 1) character of this infinite string.


Sample Input

1
2
4
8


Sample Output

T
.
^
T

分析:本题的规律很明显,第三个串由前两个串拼接,这和非波拉其数列的定义一致,所以我们可以先求出串长的非波拉其数列,存放在数组中,然后求解每组数据;由于当前串是前两个串拼接而来,对于给定的n,可以找到大于n的最小的串长,那么n一定在前两个串中,假设紧邻的三个串分别是A,B,C,当前n在C中,由于n大于B,所以n一定在A中,由题意,A在B后,所以n-len(B)即在A中的位置,如此循环直到n小于7.


#include <cstdio>

using namespace std;
const int maxn = 1000000;
const char* str = "T.T^__^";
typedef long long LL;
LL fibo[maxn];

int main()
{
	LL n;
	fibo[0] = 4; fibo[1] = 3;
	for(int i=2; i<maxn; i++) {
		fibo[i] = fibo[i-1] + fibo[i-2];
	}
	while(~scanf("%llu",&n)) {
		while(n>7) {
			int i = 0;
			while(i<maxn && fibo[i]<n) i++;
			n -= fibo[i-1];
		}
		printf("%c\n", str[n-1]);
	}
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值