ZOJ Problem Set - 1633 Big String(斐波拉契)

8 篇文章 0 订阅
5 篇文章 0 订阅

Big String

Time Limit: 2 Seconds       Memory Limit: 65536 KB

We will construct an infinitely long string from two short strings: A = "^__^" (four characters), and B = "T.T" (three characters). Repeat the following steps:
  • Concatenate A after B to obtain a new string C. For example, if A = "^__^" and B = "T.T", then C = BA = "T.T^__^".
  • Let A = B, B = C -- as the example above A = "T.T", B = "T.T^__^".
Your task is to find out the n-th character of this infinite string.


Input

The input contains multiple test cases, each contains only one integer N (1 <= N <= 2^63 - 1). Proceed to the end of file.


Output

For each test case, print one character on each line, which is the N-th (index begins with 1) character of this infinite string.


Sample Input

1
2
4
8


Sample Output

T
.
^
T

题意:

我们将从两个短字符串构造一个无限长的字符串:A = ^ __ ^(四个字符)和B = "T.T”(三个字符)。

重复以下步骤:   

连接后B获得一个新的字符串c。

例如,如果一个= B =“^ __ ^ T.T”,那么C =BA= " T.T ^ __ ^”。   

让A = B, B = C就像上面的例子。A = "T.T", B = "T.T^__^".

你的任务是找出无限第n个字符的字符串。

解题思路:

不要被题目迷惑,就是个简单的斐波拉契题。

虽然题目的字符串叠加后有一定规律,但是还是感觉和输入的数据n没有直接关系,但是如果从字符串长度找规律还是能发现的。

a=4, b=3, c=7

字符串长度就是个斐波拉契数列


AC:

#include <cstdio>
#include <iostream>
#include <string>
#define LEN 88
using namespace std;


int main()
{
	string base="T.T^__^";
	long long int f[LEN];
	f[0]=7;
	f[1]=10;
	for(int i=2; i<LEN; i++)
		f[i] = f[i-1]+f[i-2];
	long long int n;
	while(cin>>n)
	{
		while(n>7)
		{
			int i=0;
			while(i<LEN && f[i]<n)
				i++;
			n-=f[i-1];
		}
		cout<<base[n-1]<<endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值