HDU - 1042 N!

Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N! 
 

Input

One N in one line, process to the end of file. 
 

Output

For each N, output N! in one line. 
 

Sample Input

    
    
1 2 3
 

Sample Output

    
    
1 2 6

分析:大数据,注意n=0输出1


#include <cstdio>

using namespace std;
const int MODE = 100000;
const int maxn = 10000;
int fac[maxn];

int main()
{
    int n;
    while(~scanf("%d", &n)) {
		if(n==0) { printf("1\n"); continue; }
		int index = maxn - 1;
		fac[index] = n;
        for(int i=2; i<n; i++) {
			int c = 0;
            for(int j=maxn-1; j>=index; j--) {
				c += fac[j]*i;
				fac[j] = c%MODE;
				c /= MODE;
            }
            while(c>0) { fac[--index] = c%MODE; c/=MODE; }
        }
        printf("%d", fac[index]);
        for(int i=index+1; i<maxn; i++) {
			printf("%05d", fac[i]);
        }
        putchar('\n');
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值