八数码--HDU - 1043 Eight

Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
 r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement. 
 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8 
 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases. 
 

Sample Input

    
    
2 3 4 1 5 x 7 6 8
 

Sample Output

    
    
ullddrurdllurdruldr


分析:典型的八数码问题,整个搜索过程看成图的遍历,每个数码状态即图的结点,采用bfs遍历求最短路;要注意数码状态的保存可以用hash,标准库会超时;另一种方法是逆向bfs计算所有可能的状态,然后用输入判断遍历结果:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int maxn = 500000;
const int dr[] = { -1, 0, 1, 0 };
const int dc[] = { 0, 1, 0, -1 };
const char chd[] = {'u', 'r', 'd', 'l'};
const int goal[] = { 1, 2, 3, 4, 5, 6, 7, 8, 0 };
typedef int State[9];
State st[maxn], src;
int parent[maxn], id[maxn], dis[maxn], vis[362880], fact[9];
char dir[maxn], ans[maxn];

void print_path(int u)
{
	vector<char> ans;
	while(u != 1) {
		ans.push_back(dir[u]);
		u = parent[u];
	}
	for(int i=0; i<ans.size(); i++) putchar(ans[i]);
	putchar('\n');
}

bool unvisit(int s)
{
	int sum = 0;
	for(int i=0; i<9; i++) {
		int cnt = 0;
		for(int j=i+1; j<9; j++) if(st[s][j]<st[s][i]) cnt++;
		sum += fact[8-i]*cnt;
	}
	if(vis[sum]) return false;
	id[sum] = s;
	return vis[sum]=1;
}

int bfs()
{
	memset(vis, 0, sizeof(vis));
	int front = 1, rear = 2;
	unvisit(1); dis[front] = 0;
	while(front < rear) {
		State& s = st[front];
		//if(memcmp(s, goal, sizeof(goal)) == 0) return front;
		int z;
        for(z=0; z<9; z++) if(!s[z]) break;
        int x = z/3, y = z%3;
        for(int d=0; d<4; d++) {
			int newx = x + dr[d];
			int newy = y + dc[d];
			int newz = newx*3 + newy;
			if(newx>=0&&newx<3 && newy>=0&&newy<3) {
				State& t = st[rear];
                memcpy(&t, &s, sizeof(s));
                t[newz] = s[z];
                t[z] = s[newz];
				dir[rear] = chd[(d+2)%4];
                if(unvisit(rear)) {
					dis[rear] = dis[front] + 1;
					parent[rear] = front;
					rear++;
                }
			}
        }
        front++;
	}
	return 0;
}

int main()
{
	char tmp;
	fact[0] = 1;
	for(int i=1; i<9; i++) fact[i] = fact[i-1]*i;
	memcpy(st[1], goal, sizeof(goal));
	bfs();
	while(cin >> tmp) {
		if(tmp == 'x') tmp='0'; src[0] = tmp-'0';
		for(int i=1; i<9; i++) {
			cin >> tmp;
			if(tmp == 'x') src[i] = 0;
			else src[i] = tmp-'0';
		}

        int sum = 0;
        for(int i=0; i<9; i++) {
			int cnt = 0;
			for(int j=i+1; j<9; j++) if(src[j]<src[i]) cnt++;
			sum += fact[8-i]*cnt;
        }
        if(!vis[sum]) printf("unsolvable\n");
        else print_path(id[sum]);
	}
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值