问题 A: Speech Patterns (25)

时间限制: 1 Sec  内存限制: 32 MB
提交: 449  解决: 146
[提交][状态][讨论版][命题人:外部导入]

题目描述

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

输入

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入

Can1: "Can a can can a can?  It can!"

样例输出

can 5

[提交][状态]

 

解题思路

string类型的处理

对于string类型,它是一个对象,我们尽量使用string对象的方法来操纵它,如push_back(), clear()等等,避免直接对其赋值。

map容器的遍历

迭代器遍历:

for(auto it: mp){} 。

下标访问是不行的。因为下标为string 则没有有序表的规律来对其进行遍历。

AC代码

#include <iostream>
#include <map>
#include <cctype>
using namespace std;
int main(){
	map<string, int> mp;
	string ss, str;
	getline(cin, ss);
	ss+=".";
	//cout << ss<< endl;
	for(int i=0; i<ss.length(); i++){
		if(isalnum(ss[i])){
			str.push_back(tolower(ss[i]));
		}else{
			if(!str.empty()){
				mp[str]++;
			}
			str.clear();
		}
    }
    map<string, int>::iterator max=mp.begin();
	for(auto it=mp.begin(); it!=mp.end(); it++){
        if(max->second < it->second) max = it;
	}
	cout<< max->first << " " << max->second <<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值