HDU2859 Phalanx DP

Phalanx

Time Limit:5000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Description

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc

Input

There are several test cases in the input file. Each case starts with an integer n (0

Output

Each test case output one line, the size of the maximum symmetrical sub- matrix.

Sample Input

3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output

3
3

题解

一开始想了很久没想出来…脑子还是不够灵活,搜了很多题解才慢慢明白做法。
对每个点对它上面和右边的点进行匹配,如果匹配量大于右上角记录的矩阵最大的值,那么这个值就+1,否则就等于匹配量

代码

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;

char mar[1001][1001];
int dp[1001][1001];
int main()
{
    int n;
    while (scanf("%d",&n)&& n)
    {
        for (int i = 0;i<n;i++)
           scanf("%s",&mar[i]   );
        int maxn = 1;
        for (int i = 0;i<n;i++)
        {
           for (int j = 0;j<n;j++)
           {
                if (i == 0 || j == n-1)
                {
                   dp[i][j] = 1;
                   continue;
                }

                int t1 = i;int t2 = j;
                while (t1>=0 && t2<n && mar[t1][j] == mar[i][t2])
                {
                   t1--;
                   t2++;
                }
                int a = i-t1;
                if (a >= dp[i-1][j+1]+1)
                   dp[i][j] = dp[i-1][j+1]+1;
                else
                   dp[i][j] = a;
                if (dp[i][j] > maxn)
                        maxn = dp[i][j];
           }
        }
        printf("%d\n",maxn);
        memset(dp,0,sizeof(dp));
        memset(mar,0,sizeof(mar));
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值