poj 1089 Intervals

先上题目

源链接
There is given the series of n closed intervals [ai; bi], where i=1,2,…,n. The sum of those intervals may be represented as a sum of closed pairwise non−intersecting intervals. The task is to find such representation with the minimal number of intervals. The intervals of this representation should be written in the output file in acceding order. We say that the intervals [a; b] and [c; d] are in ascending order if, and only if a <= b < c <= d. 
Task 
Write a program which: 
reads from the std input the description of the series of intervals, 
computes pairwise non−intersecting intervals satisfying the conditions given above, 
writes the computed intervals in ascending order into std output

Input

In the first line of input there is one integer n, 3 <= n <= 50000. This is the number of intervals. In the (i+1)−st line, 1 <= i <= n, there is a description of the interval [ai; bi] in the form of two integers ai and bi separated by a single space, which are respectively the beginning and the end of the interval,1 <= ai <= bi <= 1000000.

Output

The output should contain descriptions of all computed pairwise non−intersecting intervals. In each line should be written a description of one interval. It should be composed of two integers, separated by a single space, the beginning and the end of the interval respectively. The intervals should be written into the output in ascending order.

Sample Input

5
5 6
1 4
10 10
6 9
8 10

Sample Output

1 4
5 10

英语渣渣啊、、、、昨天看了半天,没看懂什么意思,现在看来也不难o(^▽^)o
英语不好是硬伤啊(╯﹏╰)
总之,意思就是先输入一个n,表示下面有n组数据。然后接下来的n行就是n个小区间。让你把这些区间合并,再输出。
先把区间排序,然后再合并
废话不说,上代码


 #include <iostream>
 #include <cstdio>
 #include <algorithm>
using namespace std;
struct node
{
public:
    int x, y;
    int input()
    {
        return scanf("%d%d", &x, &y);
    }
}t[50000];
bool cmp(node u, node v)
{
    if (u.x == v.x)
    {
        return u.y < v.y;
    }
    else
    {
        return u.x < v.x;
    }
}
int main()
{
 #ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
 #endif
    int n;
    int i, j, k;
    int min, left, right;
    while(~scanf("%d", &n)) 
    {
        for (i = 0; i < n; i++)
        {
            t[i].input();
        }
        sort(t, t + n, cmp);//排序,先按x,x相同的按y排。升序
        left = t[0].x;
        right = t[0].y;
        for (i = 1; i < n; i++)
        {
            if (t[i].x > right)
            {
                printf("%d %d\n", left, right);
                left = t[i].x;
                right = t[i].y;
            }
            else if (right < t[i].y)
            {
                right = t[i].y;
            }
        }
        printf("%d %d\n", left, right);

    }
    return 0;
} 

好好学英语啊╥﹏╥…

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值