poj 3984迷宫问题

poj 3984迷宫问题


Description

定义一个二维数组:


int maze[5][5] = {

    0, 1, 0, 0, 0,

    0, 1, 0, 1, 0,

    0, 0, 0, 0, 0,

    0, 1, 1, 1, 0,

    0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

题目很简单,按广度优先搜索就行了。
↓↓↓↓↓上代码   <( ̄ˇ ̄)/   ↓↓↓↓↓

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long ll;
const long long M = 1e9+7;
const int dir[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};
int map[5][5], ans = 0, vis[5][5];
struct NODE
{
    int x, y, now, next;
}node[50];
void bfs()
{
    int i, j, t = 0;
    node[0].x = 4;      //从出口往回走,便于输出路径 
    node[0].y = 4;
    node[0].now = 0;
    node[0].next = 0;
    queue<NODE> q;
    q.push(node[0]);
    vis[4][4] = 1;
    while(!q.empty())
    {
        NODE now = q.front();
        q.pop();
        if (!now.x && !now.y)   //到达出口,开始输出路径 
        {
            t = now.now;
            while(1)
            {
                printf("(%d, %d)\n", node[t].x, node[t].y);
                if (!t)
                {
                    return ;
                }
                t = node[t].next;
            }
        }
        for (i = 0; i < 4; i++)
        {
            int nx = now.x + dir[i][0];
            int ny = now.y + dir[i][1];
            if (vis[nx][ny] || map[nx][ny] || nx < 0 || ny < 0 || nx >= 5 || ny >= 5)
            {
                continue;
            }
            t ++;
            vis[nx][ny] = 1;
            node[t].x = nx;
            node[t].y = ny;
            node[t].next = now.now;
            node[t].now = t;
            q.push(node[t]);
        }

    }
}

int main()
{
#ifndef  ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int i, j;
    for (i = 0; i < 5; i++)
    {
        for (j = 0; j < 5; j++)
        {
            cin >> map[i][j];
        }
    }
    bfs();
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值