HDU-3466-Proud Merchants(01背包问题)

Problem Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

Input

There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

Output

For each test case, output one integer, indicating maximum value iSea could get.

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output

5
11


要先按照Q-P排序,然后在按01背包处理

为什么要排序呢?我们应该先买Q-P最大的物体,然后买第二大、第三大、、、 最后买最小的。这个性质是这个问题的关键。
代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#define N 504
#define INF 1000000001
#define ll long long
using namespace std;
struct node
{
    int price, vaule, q;
    friend bool operator < (node a, node b)
    {
        return a.q-a.price < b.q-b.price;
    }
}aa[N];
int dp[5005];
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int i, j, k;
    int n, m;
    while(cin >> n >> m)
    {
        for (i = 0; i < n; i++)
            cin >> aa[i].price >> aa[i].q >> aa[i].vaule;
        sort(aa, aa+n);
        memset(dp, 0, sizeof(dp));
        for (i = 0; i < n; i++)
            for (j = m; j >= aa[i].q; j--)
                dp[j] = max(dp[j], dp[j-aa[i].price]+aa[i].vaule);
        cout << dp[m] << endl;
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值