Description
Farmer John’s cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.
Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John’s N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].
But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.
For each cow, how many cows are stronger than her? Farmer John needs your help!
Input
The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.
The end of the input contains a single 0.
Output
For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.
Sample Input
3
1 2
0 3
3 4
0
Sample Output
1 0 0
Hint
Huge input and output,scanf and printf is recommended.
这个题要把y按不降排序,x不升排序。不过注意其中可以有完全重合区间;
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#define N 100005
#define ll long long
using namespace std;
struct point
{
int l, r, index;
friend bool operator < (point a, point b)
{
if (a.r == b.r) return a.l < b.l;
return a.r > b.r;
}
}cow[N];
int ans[N<<1], n, num[N];
void update(int x, int val)
{
while(x <= n)
{
ans[x] += val;
x += x&-x;
}
}
int Sum(int x)
{
int ret = 0;
while(x > 0)
{
ret += ans[x];
x -= x&-x;
}
return ret;
}
int main()
{
#ifndef ONLINE_JUDGE
freopen("1.txt", "r", stdin);
#endif
int i, j;
while(scanf("%d", &n), n)
{
memset(num, 0, sizeof(num));
memset(ans, 0, sizeof(ans));
for (i = 0; i < n; i++)
{
scanf("%d%d", &cow[i].l, &cow[i].r);
cow[i].index = i;
}
sort(cow, cow+n);
num[cow[0].index] = 0;
update(cow[0].l+1, 1);
for (i = 1; i < n; i++)
{
if (cow[i].l == cow[i-1].l && cow[i].r == cow[i-1].r)
num[cow[i].index] = num[cow[i-1].index];
else
num[cow[i].index] = Sum(cow[i].l+1);
update(cow[i].l+1, 1);
}
for (i = 0; i < n-1; i++)
printf("%d ", num[i]);
printf("%d\n", num[i]);
}
return 0;
}