微软笔试题 《Give My Text Back》

时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述
To prepare for the English exam Little Ho collected many digital reading materials. Unfortunately the materials are messed up by a malware.

It is known that the original text contains only English letters (a-zA-Z), spaces, commas, periods and newlines, conforming to the following format:

  1. Each sentence contains at least one word, begins with a letter and ends with a period.

  2. In a sentence the only capitalized letter is the first letter.

  3. In a sentence the words are separated by a single space or a comma and a space.

  4. The sentences are separated by a single space or a single newline.

It is also known the malware changes the text in the following ways:

  1. Changing the cases of letters.

  2. Adding spaces between words and punctuations.

Given the messed text, can you help Little Ho restore the original text?

输入
A string containing no more than 8192 English letters (a-zA-Z), spaces, commas, periods and newlines which is the messed text.

输出
The original text.

样例输入
my Name is Little Hi.
His name IS Little ho , We are friends.
样例输出
My name is little hi.
His name is little ho, we are friends.


简单的字符串处理题。
需要注意不能输出多余的空格,比如一行末尾如果有多个空格的话,一个也不能输出。如果是单词和逗号(或句号)之间的空格都不能输出,单词和单词之间的多个空格只能输出一个。逗号(或句号)和单词之间的多个空格只能输出一个

#include <cstdio>
int main()
{
    int blank = 0, end = 1;//end表示一句话是否结束
    //如果已经结束,下一个字母需要大写
    int pos;
    char c;
    while(~scanf("%c", &c)){
        if (c == '.'){
            putchar(c);
            end = 1;
        }else if (c == ' '){
            blank = 1;
        }else if (c == '\n'){
            putchar('\n');
            end = 1;
            blank = 0;
        }else if (c == ','){
            putchar(',');
        }else {
            if (end){
                if (c > 'Z'){
                    c -= 32;
                }
            }else{
                if (c < 'a'){
                    c += 32;
                }
            }
            if (blank){
                putchar(' ');
            }
            putchar(c);
            end = 0;
            blank = 0;
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值