HD_OJ——(1097)A hard puzzle

/*
 * Copyright (c) 2014, 烟台大学计算机学院
 * All rights reserved.
 * 文件名称:test.cpp
 * 作    者:李晓凯
 * 完成日期:2019年 3 月 16 日
 * 版 本 号:v1.0
 *
 * 问题描述:
 * 输入描述:
 * 程序输出:

 */

Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

 

 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

 

 

Output

For each test case, you should output the a^b's last digit number.

 

 

Sample Input

 

7 66 8 800

 

 

Sample Output

 

9 6

思路:

只需利用输入的a的个位数计算出多次方中有n个不同的数,再看b中有几个n,余多少,输出对应的个位数即可。

代码:

#include <iostream>

using namespace std;
int main(void)
{
    int a,b,c[10][10],i,j,t;
    while(cin>>a>>b)
    {
        j=0;
        i=a%10;           //求出第一个个位数
        c[i][j]=i;        //保存第一个各位数  
        j++;
        t=(i*i)%10;       //求出平方的第二个个位数
        for(; t!=i; j++)  //循环求总共有几个不同的个位数
        {
            c[i][j]=t;    //保存
            //cout<<c[i][j]<<endl;
            t=(t*i)%10;   //求下一个个位数
        }
//        for(int k=0; k<j; k++)
//        {
//            cout<<c[i][k]<<" ";
//        }
        if(b%j==0)    
            cout<<c[i][j-1]<<endl;
        else
            cout<<c[i][(b%j)-1]<<endl;
    }

}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值