PAT 甲级 7-1 1125 Chain the Ropes (25分)

1125 Chain the Ropes (25分)
Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

在这里插入图片描述

Your job is to make the longest possible rope out of N given segments.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104​​ .

Output Specification:
For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

绳子每次打结长度都会减小到原来的一半,那么打结的顺序会影响到最终的长度。
先小的打结,大的最后打。

#include<bits/stdc++.h>
using namespace std;
int n,len;
int main() {
	cin >> n;
	vector<int> v(n);
	for (int i = 0; i < n; i++) scanf("%d", &v[i]);
	sort(v.begin(), v.end());
	len = v[0];
	for (int i = 1; i < n; i++) {
		len = (len + v[i]) / 2;
	}
	printf("%d", len);
	return 0;
}
#include<bits/stdc++.h>
using namespace std;
int v[10010],n.i; 
int main() {
	cin >> n;
	for (i = 0; i < n; i++) scanf("%d", &v[i]);
	sort(&v[0],&v[n]);
	int len = v[0];
	for (int i = 1; i < n; i++) {
		len = (len + v[i]) / 2;
	}
	printf("%d", len);
	return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

隔壁de小刘

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值