【PAT甲级 - C++题解】1125 Chain the Ropes

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1125 Chain the Ropes (pintia.cn)
🔑中文翻译:结绳
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1125 Chain the Ropes

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-Mq2Q6ol2-1671843374397)(PAT 甲级辅导.assets/46293e57-aa0e-414b-b5c3-7c4b2d5201e2.jpg)]

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14
题意

给定 n 个绳子的长度,每两个绳子合并长度就会减少一半,需要求出所有绳子合并后长度的最大值,输出的是整数(向下取整)。

思路

绳子合并的顺序不同会导致最终的结果不同,例如有三根绳子 {1,2,3} ,如果想让前两个合并再和第三根合并,最终的绳子长度为 ((1+2)/2+3)/2=2.25 ;而如果先让第一根和第三根合并再和第二根合并,最终的绳子长度为 ((1+3)/2+2)/2=2

直接上结论,这其实有一点像哈夫曼树但又不完全相似,我们每次合并都去合并最小的那两根绳子,这样最后得到的长度一定是最大的。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
double a[N];
int n;

int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> a[i];

    //进行排序
    sort(a, a + n);

    //计算最大长度并输出
    for (int i = 1; i < n; i++)    a[0] = (a[0] + a[i]) / 2;
    cout << (int)a[0] << endl;

    return 0;
}
  • 14
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 12
    评论
评论 12
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值