PAT - 甲级 - 1125. Chain the Ropes (25)

题目描述:

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2 <= N <= 104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:
8
10 15 12 3 4 13 1 15
Sample Output:
14

题目思路:

看到题目后,我的第一反应是贪心法,一定要将这些绳子按照长度排序,而选择身子的顺序无非有三种,从小到大,从大到小,从中间到两边。绳子每进行一次连接就要对折一次,长度就会减少一半,那么应该让较长的绳子尽量少对折。按照这样的想法,那么应该将绳子从小到大排列,两两进行串连。

题目代码:

#include<cstdio>
#include<algorithm>
#define MAXN 10001
using namespace std;
int n, a[MAXN];
int main()
{
	scanf("%d",&n);
	for(int i=0; i<n; i++) scanf("%d", &a[i]);
	
	sort(a,a+n);
	
	int ans = a[0];
	for(int i=1 ;i<n ;i++){
		ans = (ans + a[i])/2;
	}
	
	printf("%d\n",ans);	
} 





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值