hdoj 2717 Catch That Cow 【bfs】

11 篇文章 0 订阅

Catch That Cow

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 88   Accepted Submission(s) : 36
Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 orX + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 
Sample Input
  
  
5 17
 

Sample Output
  
  
4
 

Source
PKU
 
分析:老头要去抓住他的牛,已经知道牛的位置,和自己的位置,老头可以前进一步或者退一步,或者传送到当前位置数字的二倍的位置。计算老头需要几步能抓住他的牛。
 
代码:
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;

int n,m;
int vis[200000];

struct node{
	int x,y,step;
}pp;
queue<node>q;
int  bfs()
{
	while(!q.empty())
	{
		q.pop();
	}
	q.push(pp);
	memset(vis,0,sizeof(vis));
	vis[pp.x]=1;
	while(!q.empty())
	{
		node gg=q.front();
		if(gg.x==m)
		return gg.step;
		q.pop();
		for(int i=0;i<3;i++)
		{
			node dd=gg;
			if(i==0)
			dd.x=dd.x+1;
			else if(i==1)
			dd.x=dd.x-1;
			else if(i==2)
			dd.x=dd.x*2;
			dd.step++;
			if(dd.x==m)
			return dd.step;
			if(dd.x>=0&&dd.x<=200000&&!vis[dd.x])
			{
				vis[dd.x]=1;
				q.push(dd);
			}
			
		}
	}
	return 0;
//	memset(bis,0,sizeof(vis));
}




int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
         pp.x=n;
		 pp.step=0;
		 int time=bfs();
		 printf("%d\n",time);		
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值