hdoj2717Catch That Cow(BFS)

117 篇文章 0 订阅
7 篇文章 0 订阅
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output

4

题意:老农捉牛,告诉你人和牛的坐标,人可以走+1,-1,*2,牛不动 求捉住老牛最短时间

思路:最短时间搜索用bfs,建立一个数组保存步数,从老农步数开始搜索直到老牛位置输出步数。

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<string.h>
#define MAXN 110000
using namespace std;
int vis[2*MAXN];
int n,m;
int bfs(int p,int l)
{
	int t=0;
	queue<int>q;
	vis[p]=0;
	q.push(p);
	while(!q.empty())
	{
		int b=q.front();
		q.pop();
		if(b==l)
		return vis[b];
		for(int i=0;i<3;i++)
		{
			int k;
			if(i==0)
			k=b+1;
			if(i==1)
			k=b-1;
			if(i==2)
			k=b*2;
			if(k<MAXN&&!vis[k]&&k>=0)
			{
			vis[k]=vis[b]+1;
			q.push(k);	
			}
		}
	}
	return 0;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(vis,0,sizeof(vis));
		if(n>m)
		printf("%d\n",n-m);
		else
		{
		int ans=bfs(n,m);
		printf("%d\n",ans);	
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值