nyoj 364 【dp】

田忌赛马

时间限制: 3000 ms  |           内存限制: 65535 KB
难度: 3
描述
Here is a famous story in Chinese history.

"That was about 2300 years  ago. General Tian Ji was a high official in the country Qi. He likes to play  horse racing with the king and others."

"Both of Tian and the king have  three horses in different classes, namely, regular, plus, and super. The rule is  to have three rounds in a match; each of the horses must be used in one round.  The winner of a single round takes two hundred silver dollars from the  loser."

"Being the most powerful man in the country, the king has so nice  horses that in each class his horse is better than Tian's. As a result, each  time the king takes six hundred silver dollars from Tian."

"Tian Ji was  not happy about that, until he met Sun Bin, one of the most famous generals in  Chinese history. Using a little trick due to Sun, Tian Ji brought home two  hundred silver dollars and such a grace in the next match."

"It was a  rather simple trick. Using his regular class horse race against the super class  from the king, they will certainly lose that round. But then his plus beat the  king's regular, and his super beat the king's plus. What a simple trick. And how  do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more,  were he sitting in the ACM contest right now, he may discover that the horse  racing problem can be simply viewed as finding the maximum matching in a  bipartite graph. Draw Tian's horses on one side, and the king's horses on the  other. Whenever one of Tian's horses can beat one from the king, we draw an edge  between them, meaning we wish to establish this pair. Then, the problem of  winning as many rounds as possible is just to find the maximum matching in this  graph. If there are ties, the problem becomes more complicated, he needs to  assign weights 0, 1, or -1 to all the possible edges, and find a maximum  weighted perfect matching...

However, the horse racing problem is a very  special case of bipartite matching. The graph is decided by the speed of the  horses --- a vertex of higher speed always beat a vertex of lower speed. In this  case, the weighted bipartite matching algorithm is a too advanced tool to deal  with the problem.

In this problem, you are asked to write a program to  solve this special case of matching problem.
输入
The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
样例输出
200
0
0
分析:

1、当田忌最快的马比齐王最快的马快时,用田忌最快的马对抗齐王最快的马,赢一场。

2、当田忌最慢的马比齐王最慢的马快时,用田忌最慢的马对抗齐王最慢的马,赢一场。

3、当1、2都不满足时,用田忌最慢的马对抗齐王最快的马,若田忌最慢的马比齐王最快的慢时,输一场,否则平局。

代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1005;
int tj[N],hd[N];
bool cmp(int a,int b)
{
    return a>b;
}
int judge(int n)
{
    sort(tj,tj+n,cmp);
    sort(hd,hd+n,cmp);
    int tl=0,tr=n-1,kl=0,kr=n-1,win=0,lose=0;
    while(tl<=tr)
    {
        if(tj[tl]>hd[kl])
        {
            win++;
            tl++;
            kl++;
        }
        else if(tj[tr]>hd[kr])
        {
            win++;
            tr--;
            kr--;
        }
        else {
            if(tj[tr]<hd[kl])
                lose++;
            tr--;
            kl++;
        }
    }
    return (win-lose)*200;
}
int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d",&tj[i]);
        for(i=0;i<n;i++)
            scanf("%d",&hd[i]);
        printf("%d\n",judge(n));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值