nyoj364(贪心算法~好题)

田忌赛马

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
输入
The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
样例输出
200
0
0
来源

hdu


题目大意:田忌和齐王各有n匹马,田忌要么赢要么就是和齐王打成平手,赢一场会有100个金币,输一场,会输100个金币.问田忌最多赢多少金币.


解体思路:比赛时没写出来,觉得好难啊.看了解题报告,用贪心写,是这样分析的.

1)田忌最慢的马比齐王最慢的马快.直接赢一场.

2)田忌最慢的马比齐王最慢的马慢,让其输给齐王的快马,同样是输,不如输的有价值,拉底齐王的平均水平.

3)田忌最慢的马与齐王最慢的马一样慢.打平手?no!打平是下下策,为什么呢?

因为自己后面的队友很有可能战胜此时对方的这匹慢马,所以就算自己输一场,队友也能帮忙赢回一场,而胜一场,输一场的收益和打平一场的收益是一样的,而且自己输的时候可以拉对方最快的马下水,给己方最快的马创造更大的胜利机会(因为它失去了一个强劲的对手),也就是说己方最快的马很可能因为自己的牺牲再胜利一场,从这个角度看,还是自己故意输掉比较好。但是如果自己最快的马就比对方的快,那就别故意放水了.本身就能赢,还故意输那就太亏了.

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int v1[1010];
int v2[1010];
int n;
void race(){
	int win,lose;
	int t_slow,k_slow,t_first,k_first;
	win=lose=t_slow=k_slow=0;
	t_first=k_first=n-1;
	while(t_slow <= t_first)  
    {  
        if(v1[t_slow] > v2[k_slow])        //情况1  
        {  
            win++;  
            t_slow++;  
            k_slow++;  
        }  
        else if(v1[t_slow] < v2[k_slow])   //情况2  
        {  
            lose++;  
            t_slow++;  
            k_first--;  
        }  
        else                             //情况3  
        {  
            if(v1[t_first] > v2[k_first])   //我本身就赢定你了  
            {  
                win++;  
                t_first--;  
                k_first--;  
            }  
            else                        
            {  
                if(v1[t_slow] < v2[k_first]) //为了全局着想,死就死,队友会为我报仇的 
                    lose++;  
                t_slow++;  
                k_first--;  
            }  
        }  
    } 
	printf("%d\n",(win-lose)*100); 
}  
int main(){
	int i;
	while(scanf("%d",&n)!=EOF){
		for(i=0;i<n;i++){
			scanf("%d",&v1[i]);
		}
		for(i=0;i<n;i++){
			scanf("%d",&v2[i]);
		}
		sort(v1,v1+n);
		sort(v2,v2+n);
		race();
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值