PAT (Advanced Level) 1038. Recover the Smallest Number (30) 解题报告

1038. Recover the Smallest Number (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

题意:将所给的几个数字连起来,求最大

思路:用sort自定义排序,ab和ba两个用strcmp比大小,例如5,32(532 >235),02,34(0235<3402)

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
using namespace std;

struct node
{
    char name[10];
}w[10010];

int cmp(node a, node b)
{
    int la = strlen(a.name);
    int lb = strlen(b.name);
    char sa[22], sb[22];
    int t = 0;
    for(int i = 0; i < la; i++)
        sa[t++] = a.name[i];
    for(int i = 0; i < lb; i++)
        sa[t++] = b.name[i];
    sa[t] = 0;
    t = 0;
    for(int i = 0; i < lb; i++)
        sb[t++] = b.name[i];
    for(int i = 0; i < la; i++)
        sb[t++] = a.name[i];
    sb[t] = 0;
    return strcmp(sa, sb) < 0;
}

char str[101000];
int t = 0;

int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        scanf("%s", w[i].name);
    }
    sort(w, w + n, cmp);
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; w[i].name[j]; j++)
            str[t++] = w[i].name[j];
    }
    int f = 1;
    for(int i = 0; i < t; i++)
    {
        if(str[i] != '0')
        {
            printf("%s\n", str + i);
            f = 0;
            break;
        }
    }
    if(f) printf("0\n");

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值