关于新手使用Struts 2.5.16 404错误的原因

            当前最新版本的Struts2是2.5.16,然而有一些新手朋友们在按教程配置完后发现404问题,请求资源不可用。出现这个问题最多的原因是过滤器配置问题和 jar包的缘故。

             1.     org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter,这个路径中多了个ng,这是以前的版本使用的过滤器路径。然而更新到2.5.16后,会发现少了一个ng路径,重新配置一下就可以了。

             2.      jar包原因,下载2.5.16后,发现里面只给了下面这两个案例,然后很多朋友会像以前一样解压后导入里面的包,

这时,运行项目后,发现404错误。


                像以前的版本里有一个blank项目,这个项目解压后直接导包是没错的,但是我发现从这两个项目导入的包好像是有点冲突,就好像把所有的包导入一样,有冲突(个人意见),  但是我发现按照以前的blank包相应的修剪了一下导入后,项目正常运

行了。下面是我从2.5.16中对照以前的2.3.34  blank解压jar包从2.5.16 所有jar包中拿出来的,如果是新手朋友们可以先像我这样导入包。。。大神就不说了,毕竟我也是菜鸟,这样毕竟可以边编写边学习了。(适合初学者) 我不太清楚里面包的冲突关系。

展开阅读全文

没有更多推荐了,返回首页