PAT甲级1057

1057. Stack (30)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push  key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

#include<cstdio>
#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100000 + 10;
int Stack[maxn];
int top =0;//下标1位置为栈底
int N;
char command[20];
int blockrange = sqrt(maxn);
int block[1000] = { 0 };
int table[maxn] = { 0 };
void push(int x)
{
	Stack[++top] = x;
}
int popvalue;
bool pop()
{
	if (top)
	{
		popvalue = Stack[top];
		table[Stack[top]]--;
		block[Stack[top] / blockrange]--;
		top--;
		return true;
	}
	return false;
}
int peekmedian()
{
	int k = (top % 2 == 0) ? top / 2 : (top + 1) / 2;
	int sum = 0;//统计小于第k小的数之前的个数
	int index;
	for (int i = 0; i < blockrange; i++)
	{
		sum += block[i];//分块法
		if (sum >=k)
		{
			index = i;
			sum -= block[i];
			break;
		}
	}
	int	start = (index)*blockrange;//这里注意块号是从0开始的,并且注意每个块的管辖范围
	for (int i = start; i < start + blockrange; i++)
	{//这里注意记录每个数出现的次数的table的下标是从1开始的
		sum += table[i];
		if (sum >= k)
		{
			return i;
		}
	}
}
int main()
{
	scanf("%d",&N); int temp;
	for (int i = 0; i < N; i++)
	{
		scanf("%s", command);
		if (strcmp(command,"Pop")==0)
		{
			if (!pop())
			{
				printf("Invalid\n");
			}
			else
				printf("%d\n", popvalue);
		}
		else if (strcmp(command, "PeekMedian") == 0)
		{
			if (top>0)
				printf("%d\n", peekmedian());
			else
				printf("Invalid\n");
		}
		else
		{
			scanf("%d", &temp);
			table[temp]++;
			block[temp / blockrange]++;
			push(temp);
		}
	}
	return 0;
}
/*
分块法:先划分sqrt(maxn)(向上取整)个块,然后用hash表统计每个输入的数的个数
并用块表统计每个块内数字出现的总个数,注意块号从0开始,管辖范围也是从k*blocksize
开始,k=0,1,2,3...
*/

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值