PAT - 甲级 - 1127. ZigZagging on a Tree (30) ( 树的层次遍历变形 )

题目描述:

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

题目思路:

  看完题目后,首先想到的是在递归建树的时候,在递归函数中添加树的层数参数,通过对层数的奇偶性判断,确定这层结点的坐标与上层结点坐标的关系。(在层次遍历中,某某结点的编号是x,那么他的左孩子编号就是2*x,右孩子就是2*x+1),如果按照题目中要求的Z型遍历,结点之间是否还存在一定的关系。在从草稿纸上画了一会儿发现好像并没有什么关系。于是转变思路,是否可以先记录层次遍历的结果,然后在输出元素的时候判断该元素是在奇数层还是偶数层呢?回答是肯定的。这里采用了声明二维数组的方法c[i][j]表示i层上编号为j的结点。我们初始化数组结点为0,表示该结点不存在。观察题目数据范围,N<=30 也就是说,如果题目数据给出特别“变态的”树,30个结点,一层 一个结点的话。那么数组是开不下的。可以先估计一个值。博主在这里直接开了100000。

题目代码:

#include<cstdio>
#include<cstring>
using namespace std;

int a[100]; // inorder
int b[100]; // postorder 
int c[35][100000]; // c[i][j]表示第i层编号为j的元素 
int n;
// p1 p2 q1 q2表示中序和后序的头尾元素下标
// x lev 分别表示当前结点的标号和所在层数 
void dfs(int p1, int p2, int q1, int q2, int x, int lev){
	if(p1 > p2 || q1 > q2) return ;
	int i = p1;
	while(a[i] != b[q2]) i++;
	
	c[lev][x] = b[q2];
	dfs(p1, i-1, q1, q1+i-1-p1, 2*x ,lev+1);
	dfs(i+1, p2, q1+i-p1, q2-1, 2*x+1 ,lev+1);
}

int main(){
	scanf("%d",&n);
	memset(c,0,sizeof(c));
	for(int i = 0; i < n; i++) scanf("%d",&a[i]);
	for(int i = 0; i < n; i++) scanf("%d",&b[i]);
	//第一层为0层,编号为1 
	dfs(0,n-1,0,n-1,1,0);
	int cnt = 0;
	
	for(int i = 0; i < 35; i++){
		//奇数层左->右 
		if(i&1){
			for(int j = 0; j < 100000; j++){
				if(c[i][j]) printf(" %d",c[i][j]);
					
			}
		}
		else{
			//偶数层右->左  
			for(int j = 100000-1; j>=0 ;j--){
				if(c[i][j]){
					if(!cnt){
						cnt=1;
						printf("%d",c[i][j]);
					}else{
						printf(" %d",c[i][j]);
					}
				}
			}
		}
	}
	printf("\n"); 
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值