hdu1232 畅通工程

畅通工程
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39953 Accepted Submission(s): 21214

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。

Sample Input

4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0

Sample Output

1
0
2
998

Hint
Hint

Huge input, scanf is recommended.

先确定有几个连通分量,然后看将这几个联通分量连接成一个连通图需要几条边,上并查集,读入一个就判断一次,然后合并,读入数据完成之后。从第二个城镇开始,依次判断其和城镇1是否在一个连通分量,如果不在,计数+1,合并两个分量。最后输出计数。

后来发现走了弯路,要判断有几个连通分量只需要看数组中元素与下标相同的个数,即为连通分量的个数,将其减一,就是链接这几个连通分量所需要的最短路数。

修改前的代码:

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<map>
#include<queue>
#include<list>
#include<stack>
#include<cctype>
#include<fstream>
#include<sstream>
#include<iomanip>
#include<set>
#include<vector>
#include<cstdlib>
#include<time.h>
using namespace std;

int p[1005];
int find(int x)
{
    if (x != p[x])
        p[x] = find(p[x]);
    return p[x];
}
void unio(int x, int y)
{
    int px = find(x);
    int py = find(y);
    if (px == py)
        return;
    p[px] = py;
}
void make(int x)
{
    for (int i = 1; i <= x; i++)
        p[i] = i;
}
int main()
{
    int n, m;
    while (scanf("%d",&n),n)
    {
        scanf("%d", &m);
        int a, b;
        make(n);
        for (int i = 1; i<= m; i++)
        {
            scanf("%d%d", &a, &b);
            if (find(a) != find(b))
                unio(a, b);
        }
        int s = 0;
        for (int i = 2; i <= n; i++)
        {
            if (find(1) != find(i))
            {
                s++;
                unio(i,1);
            }
        }
        printf("%d\n", s);
    }
    return 0;
}

修改后代码;

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<map>
#include<queue>
#include<list>
#include<stack>
#include<cctype>
#include<fstream>
#include<sstream>
#include<iomanip>
#include<set>
#include<vector>
#include<cstdlib>
#include<time.h>
using namespace std;

int p[1005];
int find(int x)
{
    if (x != p[x])
        p[x] = find(p[x]);
    return p[x];
}
void unio(int x, int y)
{
    int px = find(x);
    int py = find(y);
    if (px == py)
        return;
    p[px] = py;
}
void make(int x)
{
    for (int i = 1; i <= x; i++)
        p[i] = i;
}
int main()
{
    int n, m;
    while (scanf("%d",&n),n)
    {
        scanf("%d", &m);
        int a, b;
        make(n);
        for (int i = 1; i<= m; i++)
        {
            scanf("%d%d", &a, &b);
            if (find(a) != find(b))
                unio(a, b);
        }
        int s = 0;
        for (int i = 1; i <= n; i++)
        {
            if (p[i] == i)
                s++;
        }
        printf("%d\n", s-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值