poj 2100 Graveyard Design(尺取)

37 篇文章 0 订阅
6 篇文章 0 订阅
Graveyard Design
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 5957 Accepted: 1413
Case Time Limit: 2000MS

Description

King George has recently decided that he would like to have a new design for the royal graveyard. The graveyard must consist of several sections, each of which must be a square of graves. All sections must have different number of graves. 
After a consultation with his astrologer, King George decided that the lengths of section sides must be a sequence of successive positive integer numbers. A section with side length s contains s 2 graves. George has estimated the total number of graves that will be located on the graveyard and now wants to know all possible graveyard designs satisfying the condition. You were asked to find them.

Input

Input file contains n --- the number of graves to be located in the graveyard (1 <= n <= 10 14 ).

Output

On the first line of the output file print k --- the number of possible graveyard designs. Next k lines must contain the descriptions of the graveyards. Each line must start with l --- the number of sections in the corresponding graveyard, followed by l integers --- the lengths of section sides (successive positive integer numbers). Output line's in descending order of l.

Sample Input

2030

Sample Output

2
4 21 22 23 24

3 25 26 27

solution:

此题用尺取甚好~

#include<cstdio>
using namespace std;
typedef long long ll;
const int maxn = 1e6 + 200;
struct node{
	int num, l, r;
}a[maxn];
int main()
{
	ll n;
	while (~scanf("%lld", &n))
	{
		int cnt = 0;
		ll r = 1, sum = 0;
		for (ll i = 1;i*i<=n; i++)
		{
			while (sum < n&&r*r <= n)
			{
				sum += r*r;
				r++;
			}
			if (sum == n)
			{
				a[cnt].num = r - i; a[cnt].l = i; a[cnt].r = r - 1;
				cnt++;
			}
			sum -= i*i;
		}
		printf("%d\n", cnt);
		for (int i = 0; i < cnt; i++)
		{
			printf("%d ", a[i].num);
			for (int j = a[i].l; j <= a[i].r; j++)
				printf("%d%c", j, j == a[i].r ? '\n' : ' ');
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值