1110 Complete Binary Tree (25分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8

0 1
2 3
4 5

Sample Output 1:

YES 8

Sample Input 2:

8

4 5
0 6

2 3

  • 7

Sample Output 2:

NO 1

题目大意

判断一棵树是不是完全二叉树

知识点

在这里插入图片描述

AC代码

#include<bits/stdc++.h>
using namespace std;

const int maxn=30;

int n;
int l[maxn],r[maxn];
bool hasfather[maxn];
int max_pos,last_u;

void dfs(int u,int pos){
//	cout<<"u=="<<u<<"pos=="<<pos<<endl;
	if(pos>max_pos){
		max_pos=pos;
		last_u=u;
	}
	
	if(l[u]!=-1)	dfs(l[u],pos*2);
	if(r[u]!=-1)	dfs(r[u],pos*2+1); 
}

int main(){
	cin>>n;
	memset(l,-1,sizeof l);
	memset(r,-1,sizeof r);
	for(int i=0;i<n;i++){
		string a,b;
		cin>>a>>b;
		if(a!="-")	l[i]=stoi(a),hasfather[stoi(a)]=true;
		if(b!="-")	r[i]=stoi(b),hasfather[stoi(b)]=true; 
	}
	
//	for(int i=0;i<n;i++)	cout<<l[i]<<" ";	cout<<endl;
//	for(int i=0;i<n;i++)	cout<<r[i]<<" ";	cout<<endl;
	
	int root=0;
	while(hasfather[root]) root++;
	
	dfs(root,1);
//	cout<<"mx=="<<max_pos<<endl;
	if(max_pos>n){
		cout<<"NO "<<root;
	}else{
		cout<<"YES "<<last_u;
	}
	
	return 0;
}```

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值