POJ 2632 较复杂的模拟

Crashing Robots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9040 Accepted: 3848

Description
In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input
The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.

Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of

L: turn left 90 degrees,
R: turn right 90 degrees, or
F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output
Output one line for each test case:

Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

比较水的一个题,理清思路很快就AC了,中途因为把阀值设为了4搞得wa了一下。 。一怒之下直接改成了4000就AC了。 。顺带一提。 。模拟我写的代码风格都比较。 。丑陋。 。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

typedef struct{
    int loca,sign;
}Point;

typedef struct{
    int x,y;
}POint;

Point G[150][150];
int pp[30];
POint loca[150];
int m,n;
int A,B;
POint move[10];

bool IsWall(int x,int y){
    if(x>=1&&x<=A&&y>=1&&y<=B)
        return true;
    return false;
}

int IsTrue(int x,int y){
    if(G[y][x].sign!=-1) return G[y][x].loca;
    return -1;
}

int main(){
//    freopen("data.in","r",stdin);
    int N;
    pp['E' - 'A'] = 0;
    pp['N' - 'A'] = 1;
    pp['W' - 'A'] = 2;
    pp['S' - 'A'] = 3;
    move[0].x = 1;move[0].y = 0;
    move[1].x = 0;move[1].y = 1;
    move[2].x = -1;move[2].y = 0;
    move[3].x = 0;move[3].y = -1;
    scanf("%d",&N);
    while(N--){
        scanf("%d%d",&A,&B);
        scanf("%d%d",&n,&m);
        memset(G,-1,sizeof(G));
        memset(loca,0,sizeof(loca));
        int i,j;
        for(i = 1;i<=n;i++){
            int xx,yy,kk;
            char c;
            scanf("%d %d %c",&xx,&yy,&c);
            G[yy][xx].sign = pp[c - 'A'];
            G[yy][xx].loca = i;
            loca[i].x = xx;
            loca[i].y = yy;
        }
        bool ok = true;
        for(i = 1;i<=m;i++){
            int cur,sum;
            char c;
            scanf("%d %c %d",&cur,&c,&sum);
            if(ok)
                switch (c){
                    case 'L':
                        G[loca[cur].y][loca[cur].x].sign = (G[loca[cur].y][loca[cur].x].sign + sum + 4000)%4;
                        break;
                    case 'R':
                        G[loca[cur].y][loca[cur].x].sign = (G[loca[cur].y][loca[cur].x].sign - sum + 4000)%4;
                        break;
                    case 'F':
                        int k = G[loca[cur].y][loca[cur].x].sign;
                        for(j = 0;j<sum;j++){
                            if(!IsWall(loca[cur].x + move[k].x , loca[cur].y + move[k].y)){
                                printf("Robot %d crashes into the wall\n",cur);
                                ok = false;
                                break;
                            }
                            int kk = IsTrue(loca[cur].x + move[k].x , loca[cur].y + move[k].y);
                            if(kk!=-1){
                                printf("Robot %d crashes into robot %d\n",cur,kk);
                                ok = false;
                                break;
                            }
                            G[loca[cur].y + move[k].y][loca[cur].x + move[k].x] = G[loca[cur].y][loca[cur].x];
                            G[loca[cur].y][loca[cur].x].loca = G[loca[cur].y][loca[cur].x].sign = -1;
                            loca[cur].x = loca[cur].x + move[k].x;
                            loca[cur].y = loca[cur].y + move[k].y;
                        }
                        break;
                }
        }
        if(ok) printf("OK\n");

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值