POJ 2151 概率DP

Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6096 Accepted: 2657

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

题意:
有M道题T个队,一只队要至少N个题才能成为冠军。给出每个队回答对每个题的概率。问所有的队伍至少解决一道题并且有冠军队的概率是多少。
题解:
dp[i][j][k]为第i队从j个题里解决k题的概率。则转移方程为dp[i][j][k] = dp[i][j-1][k-1]G[i][j] + dp[i][j-1][k](1.0-G[i][j])。设p为所有队都至少做出一题的概率。p1没有做出N题的概率,则p-p1即为所求。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define f(i,a,b) for(i = a;i<=b;i++)

using namespace std;

double G[1005][35];
double dp[1005][35][35];

int main()
{
    int M,T,N;
    while(scanf("%d%d%d",&M,&T,&N)&&(M||T||N)){
        int i,j,k;
        memset(dp,0,sizeof(dp));
        f(i,1,T){
            dp[i][0][0] = 1.0;
            double tem = 1.0;
            f(j,1,M){
                scanf("%lf",&G[i][j]);
                tem*=1.0-G[i][j];
                dp[i][j][0] = tem;
            }
        }

        f(i,1,T){
            f(j,1,M)
                f(k,1,j)
                    dp[i][j][k] = dp[i][j-1][k-1]*G[i][j] + dp[i][j-1][k]*(1.0-G[i][j]);
        }

        double p = 1.0;
        f(i,1,T)
            p*=(1.0-dp[i][M][0]);

        double p1 = 1.0;
        f(i,1,T){
            double tem = 0.0;
            f(j,1,N-1)
                tem+=dp[i][M][j];
            p1*=tem;
        }
        printf("%.3lf\n",p-p1);

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值