【习题3-4】UVA - 455 Periodic Strings

Description

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").
Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2


周期直接从1开始枚举到字符串长度即可,如果字符串长度是这个周期的倍数,然后判断是否为这个周期。



AC代码:

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int main()
{
    int T, i, j, flag, len;
    bool space = false;
    char s[200];
    cin >> T;
    while(T--)
    {
        if(space)
            cout << endl;
        cin >> s;
        len = strlen(s);
        for(i = 1; i <= len; i++)
        {
            if(len % i == 0)
            {
                for(j = 0, flag = 1; j < len; j++)
                {
                    if(s[j % i] != s[j])
                    {
                        flag = 0;
                        break;
                    }
                }
            }
            if(flag)
                break;
        }
        cout << i << endl;
        space = true;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值