POJ - 3278 Catch That Cow

POJ - 3278 Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

思路:

bfs,用队列实现。定义结构体node,node含两个int型变量,一个存坐标,一个存步数。初始化第一步,之后每次从队列中取出一个数,判断它的坐标+1、-1or*2能否到达目标值,若能则输出步数+1,否则将其放入队列。适当剪枝,保证加入队列的数是之前未出现的。

代码:

#include <iostream>
#include <queue>
#include <cmath>
#define N 100010
using namespace std;

int reco[N]={0};

struct node{
	int v,step;
};


int main(){
	
	int n,k;
	cin>>n>>k;
	
	
	if(n==k){
		cout<<0;
		return 0;
	} 
	
	
	queue<node> que;
	node a1;
	a1.v=n;
	a1.step=0;
	
	que.push(a1);
	
	//int count=0;
	int flag=1;
	
	while(flag){
		
		//count++;

		node p=que.front();
		que.pop();
			
		if(p.v+1==k || p.v-1==k || 2*p.v==k){
			flag=0;
			cout<<p.step+1;
			break;
		}
		else{
			node b;
			
			if(p.v+1>=0&&p.v+1<=N&&reco[p.v+1]==0){
				b.v=p.v+1;
				b.step=p.step+1;
				
				que.push(b);
				reco[p.v+1]=1;
			} 
			if(p.v-1>=0&&p.v-1<=N&&reco[p.v-1]==0){
				b.v=p.v-1;
				b.step=p.step+1;
	
				que.push(b);
				reco[p.v-1]=1;
			} 
			if(2*p.v>=0&&2*p.v<=N&&reco[2*p.v]==0){
				b.v=p.v*2;
				b.step=p.step+1;
				
				que.push(b);
				reco[2*p.v]=1;
			} 
		}
							
	}
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

u小鬼

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值