ACM-ICPC 2018 南京赛区网络预赛 A-An Olympian Math Problem

Alice, a student of grade 66, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k! =1 × 2 × ⋯ × (k − 1) × k

We denote S:

S = 1 × 1! + 2 × 2! + ⋯ + (n − 1) × (n − 1)!

Then S module n is ____________

You are given an integer n.

You have to calculate S modulo n.

Input

The first line contains an integer T(T≤1000), denoting the number of test cases.

For each test case, there is a line which has an integer nn.

It is guaranteed that 2 ≤ n ≤ 1e18.

Output

For each test case, print an integer SS modulo nn.

Hint

The first test is: S = 1 × 1 != 1, and 1 modulo 2 is 1.

The second test is: S = 1 × 1! + 2 × 2! = 5 , and 5 modulo 3 is 2.

样例输入

2
2
3

样例输出

1
2
#include <iostream>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <map>
#include <algorithm>
#include <queue>
#include <set>
#include <cmath>
#include <sstream>
#include <stack>
#include <fstream>
#include <ctime>
#pragma warning(disable:4996);
#define mem(sx,sy) memset(sx,sy,sizeof(sx))
typedef long long ll;
typedef unsigned long long ull;
const double eps = 1e-8;
const double PI = acos(-1.0);
const ll llINF = 0x3f3f3f3f3f3f3f3f;
const int INF = 0x3f3f3f3f;
using namespace std;
//#define pa pair<int, int>
//const int maxn = 1000005;
//const int mod = 1e9 + 7;
int main() {
	int T, Case = 0;
	scanf("%d", &T);
	while (T--) {
		ll n;
		scanf("%lld", &n);
		printf("%lld\n", n - 1);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值