A-An Olympian Math Problem


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536K
Problem Description
Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so
despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants
you to help him. The problem is:
We denote k! :
k!=1 2(k −1) k
We denote S :
S =11!+2 2!++ (n −1)(n −1)!
Then S module n is ____________
You are given an integer n. You have to calculate S modulo n.
Input
The first line contains an integer T(T≤1000), denoting the number of test cases. For each
test case, there is a line which has an integer n.
It is guaranteed that 2≤n≤1018
.
Output
For each test case, print an integer S modulo n.
Sample Input
2
2
3
Sample Output
1
2
Hint
The first test is:
S =11!=1
, and 1 modulo 2 is 1.
The second test is:
S =11!+2 2!= 5
, and 5 modulo 3 is 2.

/

找规律 

#include <iostream>
#include <iterator>
#include <algorithm>
#include <stdio.h>

using namespace std;

typedef unsigned long long ull;

int main()
{
    int k;
	scanf("%d", &k);
	while(k--)
    {
        ull t;
        ull result = 0;
        scanf("%llu", &t);
        printf("%llu\n", t-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值