An Olympian Math Problem(ACM-ICPC 2018 南京赛区网络预赛)

Alice, a student of grade 66, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!k!:

k! =1×2×⋯×(k−1)×k

We denote SS:

S = 1×1!+2×2!+⋯+ (n - 1) * (n-1)!

Then S module n is ____________

You are given an integer n.

You have to calculate S modulo n.

Input

The first line contains an integer T(T≤1000), denoting the number of test cases.

For each test case, there is a line which has an integer nn.

It is guaranteed that 2≤n≤1e18.

Output

For each test case, print an integer SS modulo nn.

Hint

The first test is: S=1×1!=1, and 1 modulo 2 is 1.

The second test is:S=1×1!+2×2!=5 , and 5 modulo 3 is 2.

样例输入复制

2
2
3

样例输出复制

1
2

题目来源

ACM-ICPC 2018 南京赛区网络预赛

当时不知道打表找规律,学长说 直接输出 n-1 ,,当时还有点懵逼

嗯。学长好强啊,我好菜,

 ac代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <set>
#define ll long long
using namespace std;
ll n;
/*
ll ac(ll a)
{
    ll sum=1;
    ll ans=0;
    for(int i=1;i<=a;i++)
    {
        sum=sum*i%n;
        ans=(ans%n+sum*i%n)%n;
    }
    return ans;
}
*/
int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        cout<<n-1<<endl;
    }return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值