HDU-1078

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 

 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 

 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

 

Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

 

Sample Output
37

思路:
特别记得还在大一下学期军训(5月份)的时候,第一次接触到dfs和bfs的相关题目,当时做了用了好长时间才勉强能做出几道,现在这个题看了下题解基本就掌握套路了
对于老鼠所到达的每个位置,它下一步可能到达的位置有上下左右4个方向分别走w(1=<w<=k)步,方向用t数组来记录

#include <iostream>
#include <cstdio>
#include <cstring> 
using namespace std;

int n,k;
int map[107][107];
int dp[107][107];
int t[4][2]={1,0,-1,0,0,-1,0,1};
int max(int a,int b) {
    return a>b?a:b;
}

int dfs(int x,int y)
{
    int maxn = 0;
    int ans;
    if(dp[x][y] != -1) return dp[x][y];
    else {
        for(int i = 1;i <= k;i++) 
            for(int j = 0;j < 4;j++) 
            {
                int new_x = x+t[j][0]*i;
                int new_y = y+t[j][1]*i;
                if(new_x>=0&&new_x<n&&new_y>=0&&new_y<n&&map[new_x][new_y]>map[x][y])
                {
                    ans = dfs(new_x,new_y);
                    maxn = max(ans,maxn);
                }
            }
        return dp[x][y] = maxn+map[x][y];
    }
}

int main()
{
    while(scanf("%d%d",&n,&k))
    {
        if(n==-1 && k==-1) break;
        for(int i = 0;i < n;i++) 
            for(int j = 0;j <n;j++) 
                scanf("%d",&map[i][j]);
        memset(dp,-1,sizeof(dp));
        printf("%d\n",dfs(0,0));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值