HDU-1078 FatMouse and Cheese

HDU-1078 FatMouse and Cheese

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:在n*n的图中 , 从左上角开始 , 每步只能走直线且每步最多走 k 距离 , 并且下一步的节点值要大于上一个节点值 , 求path中最大节点值之和 .

思路 : 动归: 找到 BaceCase ( 所有下一步的节点值都不大于这个节点值 ), 从这个BaceCase往回推.

如题例:BaceCase为(3,1)和(3,2) ,
在这里插入图片描述---->在这里插入图片描述---->在这里插入图片描述---->在这里插入图片描述---->在这里插入图片描述---->在这里插入图片描述

递归比较好写,代码如下:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
int n,k;
int arr[105][105];
int arr2[105][105];
bool vis[105][105];
bool nobiger(int x, int y){
    for(int dx = -1*k; dx <= k; dx++)
        if(x+dx > n || x+dx < 1) continue;
        else
            if(arr[x+dx][y] > arr[x][y]) return false;
    for(int dy = -1*k; dy <= k; dy++)
        if(y+dy > n || y+dy < 1) continue;
        else
            if(arr[x][y+dy] > arr[x][y]) return false;
    return true;
}
int most(int x, int y){
    if(x<1||y<1||x>n||y>n) return 0;//越界
    else if(vis[x][y] || nobiger(x, y)){
    //此点已经确定过最大值或者这个点周围没有可访问的点
        vis[x][y] = 1;
        return arr[x][y];
    }else{
        vis[x][y] = 1;//访问过

        int m = 0;//储存能够访问到的节点的最大值
        for(int dx = -1*k; dx <= k; dx++)//垂直方向遍历
            if(x+dx<1 || x+dx>n || arr2[x][y] >= arr2[x+dx][y]) continue;
            else m = max(m, most(x+dx, y));

        for(int dy = -1*k; dy <= k; dy++)//水平方向遍历
            if(y+dy < 1 || y+dy > n || arr2[x][y] >= arr2[x][y+dy]) continue;
            else m = max(m, most(x, y+dy));

        arr[x][y] += m;//确定(x,y)的最大值
        //printf("x:%d,y:%d,m=%d\n",x,y,m);
        return arr[x][y];
    }
}
int main(){
    while(scanf("%d%d",&n,&k) && n!=-1){
        memset(arr,0,sizeof(arr));
        memset(vis,0,sizeof(vis));
        for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++)
        scanf("%d",&(arr[i][j]));
        memcpy(arr2,arr,sizeof(arr));
        printf("%d\n",most(1,1));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值