UVA-Box

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box.
这里写图片描述
Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake.

Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.

Input

Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet and contains two integer numbers w and h (1 ≤ w, h ≤ 10 000) — width and height of the pallet in
millimeters respectively.

Output

For each test case, print one output line. Write a single word‘POSSIBLE’ to the output file if it is possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not possible to do so.

Sample Input

1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234

Sample Output

POSSIBLE
IMPOSSIBLE

题意:根据给出的六个面的长和宽,求是否可以拼成一个六面体
方法:六面体相对的两个面的长和宽必然是相等的,并且每两个面之间有一条相邻边,此边的长度也是相等的

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;

typedef struct Side
{
    int width;
    int lenth;
}Side;
Side Box[6];

bool cmp(Side x, Side y){
    return (x.lenth<y.lenth || (x.lenth==y.lenth && x.width<y.width));
}

bool isBox(){
    if(Box[0].lenth == Box[1].lenth && Box[1].lenth == Box[2].lenth &&
       Box[0].width == Box[1].width && Box[1].width == Box[4].lenth &&
       Box[2].width == Box[3].width && Box[3].width == Box[4].width &&
       Box[4].lenth == Box[5].lenth && Box[4].width == Box[5].width)
        return true;
    return false;
}

void CompareBox(){
   sort(Box, Box+5, cmp);
}

int main()
{
    int w,l;
    while(scanf("%d %d", &w, &l) != EOF){
        if(l > w){
            Box[0].lenth = w;
            Box[0].width = l;
        }
        else
        {
            Box[0].lenth = l;
            Box[0].width = w;
        }
        for(int i=1; i<6; i++){
            scanf("%d %d", &w, &l);
            if(l > w){
                Box[i].lenth = w;
                Box[i].width = l;
            }
            else
            {
                Box[i].lenth = l;
                Box[i].width = w;
            }
        }
        CompareBox();
        if(isBox())
            printf("POSSIBLE\n");
        else
            printf("IMPOSSIBLE\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值