UVA - 12293 Box Game (规律)

Description

Download as PDF


  Box Game 

There are two identical boxes. One of them contains n balls, while the other box contains one ball. Alice and Bob invented a game with the boxes and balls, which is played as follows:

Alice and Bob moves alternatively, Alice moves first. For each move, the player finds out the box having fewer number of balls inside, and empties that box (the balls inside will be removed forever), and redistribute the balls in the other box. After the redistribution, each box should contain at least one ball. If a player cannot perform a valid move, he loses. A typical game is shown below:

\epsfbox{p12293.eps}

When both boxes contain only one ball, Bob cannot do anything more, so Alice wins.


Question: if Alice and Bob are both clever enough, who will win? Suppose both of them are very smart and always follows a perfect strategy.

Input 

There will be at most 300 test cases. Each test case contains an integer n ( 2$ \le$n$ \le$109) in a single line. The input terminates by n = 0.

Output 

For each test case, print a single line, the name of the winner.

Sample Input 

2
3
4
0

Sample Output 

Alice
Bob
Alice
题意:有两个相同的盒子,其中一个盒子有n个球,另一个有1个球,每次把较小的那个数拿走,然后把较大的数分成两部分,使得操作后每个盒子至少有1个球,如果无法操作,
则当前游戏者输,判断先手(Alice)还是后手(Bob)胜
思路:可以通过SG定理打表找规律,也可以分析,假设当前为3的话,那么这个时候是先手输,然后有可能到达这个状态的有4,5,6,这些是先手胜的情况,那么7的话就是输啦,
依次类推下去,发现当n=2^k-1的时候,是Bob胜,其他的是Alice胜。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int sg[100], vis[100];

void init() {
	sg[1] = 0;
	sg[2] = 1;
	for (int i = 3; i < 100; i++) {
		memset(vis, 0, sizeof(vis));
		for (int j = (i+1)/2; j < i; j++)
			vis[sg[j]] = 1;
		for (int j = 0; ; j++)
			if (!vis[j]) {
				sg[i] = j;
				break;
			}
		printf("%d %d\n", i, sg[i]);
	}
}

int main() {
//	init();
	int n;
	while (scanf("%d", &n) != EOF && n) {
		if ((n & (n+1)) == 0)
			printf("Bob\n");
		else printf("Alice\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值