SGU 102. Coprimes

Question:

For given integer N (1<=N<=104) find amount of positive numbers not greater than N that coprime with N. Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).

Input

Input file contains integer N.

Output

Write answer in output file.

Sample Input

9

Sample Output

6


代码

#include <iostream>
#include <cstdlib>

using namespace std;

int main(int argc, char *argv[])
{
	int n, count = 1;
	cin >> n;
	for (int i = 2; i < n; i ++)	
	{
		int a = n, b = i, r;
		while (1)				//欧几里德算法(辗转相除法)求最大公约数
		{
			r = a % b;
			if (r == 0)
			{
				if (b == 1) count ++;
				break;
			}
			a = b;
			b = r;
		}
	}

	cout << count << endl;
	return EXIT_SUCCESS;
}

Mark:

1.这里使用了欧几里德算法来求最大公约数;用欧拉函数直接求结果,可能会更快。

2.开始时,把count初值设为0,然后从1开始判断,这样使得1的结果为0,不符合题目中的定义;后来把count设置为1,然后从2开始判断,AC了。

   原来的方法也可以,但是应该把 i < n 改为 i <= n 。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值