sgu 102. Coprimes 欧拉函数

102. Coprimes

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

For given integer N (1<=N<=104) find amount of positive numbers not greater than N that coprime with N. Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).

Input

Input file contains integer N.

Output

Write answer in output file.

Sample Input

9

Sample Output

6


素因数筛选查找

#include <bits/stdc++.h>

using namespace std;

bool v[10005];

void solve(){
    int n;
    scanf("%d",&n);
    if(n==1){
        printf("1");
        return;
    }
    int ans=0;
    for(int i=2;i<n;i++){
        if(n%i==0&&!v[i]){
            for(int j=i;j<n;j+=i){
                if(v[j]==0){
                    v[j]=1;
                    ans++;
                }
            }
        }
    }
    printf("%d",n-ans-1);
    return;
}

int main(){
    solve();
    return 0;
}

欧拉函数

通式:
 
其中p1, p2……pn为x的所有质因数,x是不为0的整数。
φ(1)=1(和1 互质的数(小于等于1)就是1本身)。
注意:每种质因数只一个。 比如12=2*2*3那么φ(12)=12*(1-1/2)*(1-1/3)=4
若n是质数p的k次幂,
   
,因为除了p的倍数外,其他数都跟n互质。
设n为正整数,以 φ(n)表示不超过n且与n互素的正整数的个数,称为n的欧拉函数值
φ:N→N,n→φ(n)称为欧拉函数。
欧拉函数是 积性函数——若m,n互质,
 
特殊性质:当n为奇数时,
   
, 证明与上述类似。
若n为质数则
 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值