[UVA] 101 The Blocks Problem

8 篇文章 0 订阅

题目:
Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will “program” a robotic arm to respond to a limited set of commands.
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n − 1) with block bi adjacent to block bi+1 for all 0 ≤ i < n − 1 as shown in the diagram below:
Initial Blocks World
The valid commands for the robot arm that manipulates blocks are:
• move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are
stacked on top of blocks a and b to their initial positions.
• move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.
• pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.
• pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.
• quit
terminates manipulations in the block world.
Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.
Input
The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.
You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.
Output
The output should consist of the final state of the blocks world. Each original block position numbered i (0 ≤ i < n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don’t put any trailing spaces on a line.
There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).
Sample Input
10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit
Sample Output
0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:

题意及分析:就是模拟一下操作。重点是可以要仔细分析题目,可以讲所有操作转化为2个操作。一个clear(),一个pile();意思详见紫书。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<string>
#include<cstring>
using namespace std ; 

const int N = 30 ;
vector<int> vec[N];
int n ;

void find_black(int a , int& p , int& h){//ÒýÓõĻ°ÀïÃæ²»ÓÃÖØж¨Òå 
    for( p = 0 ; p < n ; p ++){
        for( h = 0 ; h < vec[p].size() ; h++ ){
            if(vec[p][h]==a){
                return ;    
            }
        }
    }
}

void clear_above(int p , int h){
    for(int i = h+1 ; i< vec[p].size() ; i++){
        vec[vec[p][i]].push_back(vec[p][i]);
    }
    vec[p].resize(h+1);//vecÖ»±£´æϱí0~hµÄh+1¸öÔªËØ 
}

void pile_onto(int pa ,int ha ,int pb ){
    for(int i = ha ; i < vec[pa].size();i++){
        int temp = vec[pa][i];
        vec[pb].push_back(temp);
    }
    vec[pa].resize(ha);
}

int main(){
    //freopen("in.txt","r",stdin);
    while(cin>>n){
        for(int i = 0 ; i < n ; i++) vec[i].clear();
        for(int i = 0 ; i < n ;i ++){
            vec[i].push_back(i);
        }
        string s1,s2 ;
        int a , b ,ha,hb; 
        while(cin>>s1>>a>>s2>>b){
            int pa,pb;
            //printf("a=%d b=%d\n",a,b);
            find_black(a,pa,ha);
            find_black(b,pb,hb);
            if(pa==pb) continue;
            if(s1=="move") clear_above(pa,ha);
            if(s2=="onto") clear_above(pb,hb);
            pile_onto(pa,ha,pb);
        }
        for(int i = 0 ; i < n ; i++){
            printf("%d:",i);
            for(int j = 0 ;  j < vec[i].size() ; j++) printf(" %d",vec[i][j]);
            printf("\n");
        }


    }
    return 0 ;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值