hdu 2138 How many prime numbers(打srt(n)素数表加快筛素数法)

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13047    Accepted Submission(s): 4519


Problem Description
  Give you a lot of positive integers, just to find out how many prime numbers there are.
 

Input
  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

Output
  For each case, print the number of prime numbers you have found out.
 

Sample Input
  
  
3 2 3 4
 

Sample Output
  
  
2
 

Author
wangye
 

Source
HDU 2007-11 Programming Contest_WarmUp
题目分析:就是将筛素数和试素数法结合,达到对超大素数的判断优化,注意中间过程超int,wrong成狗了
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 100007

using namespace std;

typedef long long LL;

int n;
int prime[MAX];
int vis[MAX];
int cnt;

void init ( )
{
    for ( int i = 1 ; i < MAX ; i++ ) vis[i] = 1;
    cnt = 0;
    vis[1] = vis[0] = 0;
    for ( LL i = 2 ; i < MAX ; i++ )
    {
        if ( !vis[i] ) continue;
        vis[i] = cnt , prime[cnt++] = i;
        for ( LL j = i*i ; j < MAX ; j += i )
            vis[j] = 0;       
    }
}

bool check ( int num )
{
    for ( int i = 0 ; (LL)(prime[i])*(LL)(prime[i]) <= num ; i++ )
        if ( num%prime[i] == 0 ) return false;
    return true;
}

bool judge ( int num )
{
    for ( LL i = 2 ; i*i <= num ; i++ )
        if ( !(num%i) ) return false;
    return true;
}

int main ( )
{
    init ( );
   // for ( int i = 0 ; i < 500 ; i++ )
   //     cout << prime[i] << " ";
   // cout << endl;
    while ( ~scanf ( "%d" , &n ) )
    {
        int ans = 0;
        for ( int i = 1 ; i <= n ; i++ )
        {
            int a;
            scanf ( "%d" , &a );
            if ( check ( a ) ) ans++;
        }
        printf ( "%d\n" , ans );
    }
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值