hdu 1297 Children’s Queue(java+简单dp)

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11519    Accepted Submission(s): 3746


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4
 

Author
SmallBeer (CML)
题目分析:
这道题最终结果会超long long ,所以我选择了java
状态定义为dp[i][j][k],i标记当前状态是否合法,j标记最后一位是男还是女,k标记当前位;
之所以定义非法状态,是因为当前位选择女性导致的非法,可能在后一位被纠正为合法
具体转移过程见代码,其实如果java中全部定义为static,和c++基本上在编程上是没区别的
 
package hdu;

import java.util.Scanner;
import java.math.BigInteger;

public class Main 
{
	static BigInteger [][][]dp = new BigInteger[3][3][1007];
	
	static void memset ( )
	{
		for ( int i = 0 ; i < 3 ; i++ )
			for ( int j = 0 ; j < 3 ; j++ )
				for ( int k = 0 ; k < 1007 ; k++ )
					dp[i][j][k] = BigInteger.ZERO;
	}
	
	static void init ( )
	{
		 memset ();
		 dp[1][1][1] = dp[0][2][1] = BigInteger.ONE;
		 for ( int i = 2 ; i <= 1000 ; i++  )
		 {
			 dp[1][1][i] = dp[1][2][i-1].add(dp[1][1][i-1]);
			 dp[1][2][i] = dp[1][2][i-1].add(dp[0][2][i-1]);
			 dp[0][2][i] = dp[1][1][i-1];
		 }
	}
	public static void  main ( String args[] )
	{
		Scanner cin = new Scanner ( System.in );
		init();
		while ( cin.hasNext() )
		{
			int n = cin.nextInt();
			System.out.println ( dp[1][1][n].add(dp[1][2][n]) );
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值