hdu1297 Children’s Queue (动态规划,n个人排成一列的方案数+高精加)

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12548    Accepted Submission(s): 4110


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4
 

Author
SmallBeer (CML)
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1465  1133  1480  1438  1466 
 


解析:f[i] 表示队列长度为 i 时的方案数,则:f[i]=f[i-1]+f[i-2]+f[i-4]

           1.f[i-1]:最后一个为男生,前 i-1 个合法

           2.f[i-2]:最后一个为女生,那么前一个必为女生,前 i-2 个合法

           3.f[i-4]:最后一个为女生,那么前一个必为女生,i-2为女生,i-3为男生,前 i-4 个合法,这种前 i-2 个不合法的情况下加上最后两个女生就合法了。

代码:

#include<cstdio>
#include<algorithm>
using namespace std;

typedef long long LL;
const LL maxn1=1000;
const LL maxn2=100;
const LL len=1e8;
LL f[maxn1+10][maxn2];

void add(LL a[],LL b[])
{
  LL i,last=0;
  a[0]=max(a[0],b[0]);
  for(i=1;i<=a[0];i++)
    {
	  a[i]+=b[i]+last;
      last=a[i]/len,a[i]%=len;
	}
  if(last)a[++a[0]]=last;
}

int main()
{
  LL n,i;
  f[0][0]=1,f[0][1]=1;
  f[1][0]=1,f[1][1]=1;
  f[2][0]=1,f[2][1]=2;
  f[3][0]=1,f[3][1]=4;
  for(i=4;i<=maxn1;i++)
    {
      add(f[i],f[i-1]);
      add(f[i],f[i-2]);
      add(f[i],f[i-4]);
	}
  while(scanf("%I64d",&n)!=EOF)
    {
      printf("%I64d",f[n][f[n][0]]);
      for(i=f[n][0]-1;i>=1;i--)printf("%08I64d",f[n][i]);
      printf("\n");
	}
  return 0; 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值