hdu 2610 Sequence one ( dfs+可行性剪枝 )

Sequence one

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 483    Accepted Submission(s): 179


Problem Description
Search is important in the acm algorithm. When you want to solve a problem by using the search method, try to cut is very important.
Now give you a number sequence, include n (<=1000) integers, each integer not bigger than 2^31, you want to find the first P subsequences that is not decrease (if total subsequence W is smaller than P, than just give the first W subsequences). The order of subsequences is that: first order the length of the subsequence. Second order the sequence of each integer’s position in the initial sequence. For example initial sequence 1 3 2 the total legal subsequences is 5. According to order is {1}; {3}; {2}; {1,3}; {1,2}. {1,3} is first than {1,2} because the sequence of each integer’s position in the initial sequence are {1,2} and {1,3}. {1,2} is smaller than {1,3}. If you also can not understand , please see the sample carefully.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, P. (1<n<=1000, 1<p<=10000).
 

Output
For each test case output the sequences according to the problem description. And at the end of each case follow a empty line.
 

Sample Input
  
  
3 5 1 3 2 3 6 1 3 2 4 100 1 2 3 2
 

Sample Output
  
  
1 3 2 1 3 1 2 1 3 2 1 3 1 2 1 2 3 1 2 1 3 2 3 2 2 1 2 3 1 2 2
Hint
Hint : You must make sure each subsequence in the subsequences is unique.
 

Author
yifenfei
题目分析:注意几点,判重,可以根据它是子序列的性质,只需判断当前元和上一个元素间在原始串中有没有相同的元,有则重复,如果是当前串的第一位,就判断和之前所有的元中有没有相同的,然后是当前短串找不到的情况下,是找不到更长的符合条件的串的,所以剪枝时要减去,还有剩余原始串长度如果小于剩余当前的串的长度,也是一定无解的,所以要跟据这些有解的必要条件进行剪枝,也就是可行性剪枝
 
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <map>
#define MAX 1007

using namespace std;

int n,p;
int s[MAX];
int a[MAX];
int cnt;

bool check ( int s ,int e )
{
    for ( int i = s+1 ; i < e ; i++ )
        if ( a[i] == a[e] ) return false;
    return true;
}

void dfs ( int cur , int now , int len )
{
    if ( n - cur < len - now ) return;
    if ( cnt >= p ) return;
    if ( now == len )
    {
        cnt++;
        printf ( "%d" , s[0] );
        for ( int i = 1 ; i < len ; i++ )
            printf ( " %d" , s[i] );
        puts ( "" );
        return;
    }
    for ( int i = cur+1 ; i <= n ; i++ )
    {
        if ( now > 0 && a[i] < s[now-1] ) continue;
        bool mark = false;
        for ( int j = cur+1 ; j < i ; j++ )
           if ( a[j] == a[i] )
           {
               mark = true;
               break;
           } 
        //if ( now == 0 && !check ( 0 , i ) ) continue;
        //if ( now != 0 && !check ( cur , i ) ) continue;
        if ( mark ) continue;
        s[now] = a[i];
        dfs ( i , now+1 , len );
        if ( cnt == p ) return;
    }
}

int main ( )
{
    //bool flag = false;
    while ( ~scanf ( "%d%d" , &n , &p ) )
    {
        //if ( flag ) puts ("");
        //else flag = true;
        for ( int i = 1 ; i <= n ; i++ ) 
            scanf ( "%d" , &a[i] );
        cnt = 0;
        for ( int i = 1 ; i < n ; i++ )
        {
            int judge = cnt;
            dfs ( 0 , 0 , i );
            if ( cnt == judge || cnt >= p ) break;
        }
        puts("");
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值