poj 2891 Strange Way to Express Integers(线性同余方程组求解)

Strange Way to Express Integers
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 10883 Accepted: 3331

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1, a2,…, ak. For some non-negative m, divide it by everyai (1 ≤ ik) to find the remainder ri. Ifa1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai,ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I findm from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers ai,ri (1 ≤ ik).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output-1.

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

Source

POJ Monthly--2006.07.30, Static
题目分析:
这道题很明显是构建同余模方程,联立求解
那么如何求解呢
首先是考虑单个同余模方程如何求解
x ==r1(mod a1)
我们可以转换为x + a1y == r1 的形式,因为x的系数为1,所以gcd(1,a1) == 1 ,那么gcd(1,a1) = 1 | r1 ,所以同余方程一定有解
利用拓展欧几里得求取x+a1y == 1 的结果,x*r1 = a1*y*r1 = r1;
那么原同余方程得解
那么考虑两个的同余方程组,
x == r1 (mod a1 )
x == r2 ( mod a2 )
可以化为
x + a1y1 == r1
x + a2y2 == r2
a1y1 - a2y2 == r1 - r2
然后像解一个线性模方程的方法解这个方程,得到解y1
代入原式能够得到x = a1*y1+r1
然后得到(a2*y1+r2)%a1 == (a2*y1+r2)%a2
所以由同余定理得,x==(a2*y1+r2)%[a1,a2]
再与下面式子联立即可
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

typedef long long LL;

int n;

void exgcd ( LL a , LL b , LL&d , LL& x , LL& y )
{
    if ( !b )
        x = 1 , y = 0 , d = a;
    else 
        exgcd ( b , a%b , d , y , x ) , y -= x*(a/b);
}

LL solve ( int n )
{
    if ( n < 1 ) return -1;
    LL a1,r1,a2,r2,ans,a,b,c,d,x0,y0;
    bool ifhave = 1;
    scanf ( "%lld%lld" , &a1 , &r1 );
    for ( int i = 1 ; i < n ; i++ )
    {
        scanf ( "%lld%lld" , &a2 , &r2 );
        a = a1 , b = a2 , c = r2 - r1;
        exgcd ( a , b , d , x0 , y0 );
        if ( c % d != 0 )
           ifhave = 0;
       int t = b/d;
       x0 = (x0*(c/d)%t+t)%t;
       r1 = a1*x0 + r1;
       a1 = a1*(a2/d);           
    }
    if ( ! ifhave )
        r1 = -1;
    return r1;
}

int main ( )
{
    while ( ~scanf ( "%d" , &n ) )
        printf ( "%lld\n" , solve ( n ) );    
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值