HDU 1312 Red and Black 【DPS】

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13487    Accepted Submission(s): 8359


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 


 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 


 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 


 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 


 

Sample Output
  
  
45 59 6 13
 


 

Source

 

题意:

从@开始走 #是墙 计算@能走的位置 ‘.’表示可以走1地方

注意:

1:本题没有用到回溯 因为可以返回到走过的位置 但是不再增加步数

2:31行getchar()很重要

3:map 是地图 step是走下一步的方向

 

#include<stdio.h>
#include<string.h>
int a,b,ax,ay,nx,ny,s,step[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
char map[25][25];
void DFS(int x,int y)
{
    //if(x<=0||x>b||y<=0||y>a) return ;//并没什么用
    //if(map[x][y]=='#') return ;//之前这里的问题找了好久 一直没发现为什么 在被标记#后再DPS 判断#后直接return,无法进行下一步搜索
    for(int i=0; i<=3; i++)
    {
        // printf("%d %d  x\n",x,y);
        nx=x+step[i][0];
        ny=y+step[i][1];
        //if(nx<=0||nx>b||ny<=0||ny>a||map[nx][ny]=='#'||map[nx][ny]=='O') continue; 不符合的条件
        if(map[nx][ny]=='.')//符合要求
        {
            s++;
            map[nx][ny]='#';
            DFS(nx,ny);
        }
    }
}
int main (void)
{
    int i,ii;

    while(~scanf("%d%d",&a,&b),a||b)
    {
        s=0;
        memset(map,'0',sizeof(map));
        getchar();
        for(i=1; i<=b; i++)
        {
            for(ii=1; ii<=a; ii++)
            {
                scanf("%c",&map[i][ii]);
                if(map[i][ii]=='@')
                {
                    ax=i;
                    ay=ii;
                }
            }
            getchar();
        }
        s=0;
        DFS(ax,ay);
        printf("%d\n",s+1);//没有计算起点 所以+1
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值