杭电 1513 Palindrome LCS DP

67 篇文章 0 订阅
1 篇文章 0 订阅

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3955    Accepted Submission(s): 1349


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 


 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 


 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 


 

Sample Input
  
  
5 Ab3bd
 


 

Sample Output
  
  
2
 

第一次用滚动数组,感觉自己萌萌哒QAQ。

嘛,滚动数组其实并不难,关键是要用i来确定,这样会比较方便点。虽然还是有点小不理解吧,不过这都不是事儿~

#include<stdio.h>
#include<string.h>
#define maxn 5000+10
#define max(a,b) (a>b?a:b)
char s1[maxn],s2[maxn];
int dp[2][maxn];

int main(){
	int n;
	while(~scanf("%d",&n)){
		scanf("%s",s1);
		strcpy(s2,s1);
		strrev(s2);
		memset(dp,0,sizeof(dp));
		int i,j,x=0,y=1;
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				x=i%2;y=1-x;
				if(s1[i-1]==s2[j-1])
				dp[x][j]=dp[y][j-1]+1;
				else
				dp[x][j]=max(dp[y][j],dp[x][j-1]);
			}
		}
		printf("%d\n",n-dp[n%2][n]);
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值