POJ 1862 Stripies

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000


题意

即给你一定的生物,他们会有一定的重量,如果他们相互碰撞,那么根据题目给的那个公式2*sqrt(m1*m2) ,质量会减少。这个公式表示的是两个物品质量分别为m1m2,而他们碰撞后的总质量会减少为2*sqrt(m1*m2) ,给你一定的这样的生物及它们的质量,要你求它们经过碰撞后的最小总质量。


解题思路:

贪心水题。用分析POJ 3262那一题的方法分析一下。

设当前生物体的重量为x,分别和m1、m2碰撞后质量为2*sqrt(2*sqrt(m1*x)*m2);

若将m1、m2顺序对换后,质量为2*sqrt(2*sqrt(m2*x)*m1);

两者相比,结果为sqrt(m2/m1);

若希望第一个顺序生成的质量较小,则m1 > m2;

所以应先和质量大的生物碰撞。


#include "cstdio"
#include "cmath"
#include "algorithm"
using namespace std;
int a[105];

bool cmp(int x,int y)
{
	return x > y;
}

int main(int argc, char const *argv[])
{
	int N;
	int a[105];
	while(~scanf("%d",&N))
	{
		for(int i = 0;i < N;i++)
			scanf("%d",&a[i]);
		sort(a,a+N,cmp);

		double ans = a[0];
		for(int i = 1;i < N;i++)
			ans = 2*sqrt(ans*a[i]);
		printf("%.3lf\n",ans);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值