PAT - 1144 The Missing Number(20 分) || LeetCode 41. First Missing Positive

这道题同时在PAT和LeetCode中出现哈
不过PAT并没有要求用 O(1)空间复杂,可是LeetCode要求用 O(1),时间复杂度都适用O(N);

1144 The Missing Number(20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

第一个用的是O(N)空间复杂度,能过PAT,不能过LeetCode

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
void test(vector<int> nums){
    for(int i = 0; i < nums.size(); i++)
        cout << nums[i] << " ";
    cout <<  "-------------" << endl;
}

int main(){
    vector<int> nums;
    int len, number;
    cin >> len;
    if(len == 0){
      cout << 1;
      return 0;
    }
    
    while(len--){
        cin >>  number;
        nums.push_back(number);
    }
    
    sort(nums.begin(), nums.end());
    
    bool index[nums.size()] = {false};
    index[0] = true;
    
    for(int i = 0; i < nums.size(); i++){
        if(nums[i] <= 0)                 //小于等于0,跳过
            continue;
        if(nums[i] > nums.size())        //大于size,跳过
            continue;
        index[nums[i]] = true;
    }
    
    for(int i = 0; i < nums.size(); i++){
        if(index[i] == false){
            cout << i;
            return 0;
        }
    }
    cout << nums.size() + 1;
    return 0;
}
第二个用的是O(1)空间复杂度,能过LeetCode(YouTube上看的 -  - )

自己去看吧,YouTube搜 first missing positive,前几个都差不多 

class Solution {
public:
    int firstMissingPositive(vector<int>& nums) {
        for(int i = 0; i < nums.size(); i++){
            if(nums[i] <= 0)
                nums[i] = INT_MAX;
        }
        
        for(int i = 0; i < nums.size(); i++){
            int number = abs(nums[i]);
            if(number <= nums.size())
                nums[number - 1] = - abs(nums[number - 1]);
        }
        for(int i = 0; i < nums.size(); i++){
            if(nums[i] > 0)
                return i + 1;
        }
        return nums.size() + 1;
    } 
};





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值